Du kan inte välja fler än 25 ämnen Ämnen måste starta med en bokstav eller siffra, kan innehålla bindestreck ('-') och vara max 35 tecken långa.

129 rader
3.4 KiB

  1. ###################################################
  2. #
  3. # HMS NixOS Conf
  4. # 2020-8-29
  5. #
  6. { config, pkgs, ... }:
  7. {
  8. imports =
  9. [ # Include the results of the hardware scan.
  10. ./hardware-configuration.nix
  11. # home-manager config
  12. #./home.nix
  13. ];
  14. #### Boot
  15. boot.loader.grub.enable = true;
  16. boot.loader.grub.version = 2;
  17. boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
  18. #### Network
  19. networking.useDHCP = false;
  20. networking.interfaces.ens18.useDHCP = true;
  21. #### Time/Date
  22. time.timeZone = "America/Los_Angeles";
  23. #### Packages
  24. nixpkgs.config = {
  25. allowUnfree = true;
  26. };
  27. environment.systemPackages = with pkgs; [
  28. # Basics
  29. mc
  30. git
  31. wget
  32. youtube-dl
  33. tmux
  34. neofetch
  35. sakura
  36. firefox
  37. home-manager
  38. gnome3.gnome-disk-utility
  39. # WM Helpers
  40. dmenu
  41. # xdg
  42. xdg-user-dirs
  43. xdg_utils
  44. # Editors
  45. vscode
  46. nano
  47. vim
  48. # Social
  49. discord
  50. signal-desktop
  51. # Design
  52. darktable
  53. inkscape
  54. gimp
  55. # Torrents
  56. transmission
  57. # Other
  58. simplenote
  59. # Auth
  60. yubioath-desktop
  61. ];
  62. #### Services
  63. services.sshd.enable = true;
  64. #### xserver
  65. services.xserver.enable = true;
  66. services.xserver.layout = "us";
  67. # Display Manager
  68. services.xserver.displayManager.lightdm.enable = true;
  69. services.xserver.displayManager.defaultSession = "none+awesome";
  70. services.xserver.displayManager.lightdm.greeters.mini = {
  71. enable = true;
  72. user = "hms";
  73. extraConfig = ''
  74. [greeter]
  75. show-password-label = true
  76. password-label-text = Enter Credentials:
  77. invalid-password-text = Credentials Invalid
  78. show-input-cursor = true
  79. password-alignment = right
  80. show-image-on-all-monitors = false
  81. [greeter-theme]
  82. background-image = ""
  83. font = "Sans"
  84. font-size = 1em
  85. font-weight = bold
  86. font-style = normal
  87. text-color = "#080800"
  88. error-color = "#F8F8F0"
  89. background-color = "#1B1D1E"
  90. window-color = "#F92672"
  91. border-color = "#080800"
  92. border-width = 2px
  93. layout-space = 15
  94. password-color = "#F8F8F0"
  95. password-background-color = "#1B1D1E"
  96. password-border-color = "#080800"
  97. password-border-width = 2px
  98. '';
  99. };
  100. # Desktop Manager
  101. #services.xserver.desktopManager.mate.enable = true;
  102. # Window Manager
  103. services.xserver.windowManager.awesome.enable = true;
  104. #### User
  105. users.users.hms = {
  106. isNormalUser = true;
  107. home = "/home/hms";
  108. extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user.
  109. };
  110. # This value determines the NixOS release from which the default
  111. # settings for stateful data, like file locations and database versions
  112. # on your system were taken. It‘s perfectly fine and recommended to leave
  113. # this value at the release version of the first install of this system.
  114. # Before changing this value read the documentation for this option
  115. # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
  116. system.stateVersion = "20.03"; # Did you read the comment?
  117. }