You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

27 regels
1000 B

  1. { config, pkgs, ... }:
  2. {
  3. # Let Home Manager install and manage itself.
  4. programs.home-manager.enable = true;
  5. # awesome window manager config
  6. ## xdg will automaticly append /home/USER-NAME/.config/ to the "something".source part of the
  7. ## xdg.configFile."something".source = "/etc/nixos/wm/awesome/rc.lua"; config option
  8. xdg.configFile."awesome/rc.lua".source = "/etc/nixos/wm/awesome/rc.lua";
  9. # Home Manager needs a bit of information about you and the
  10. # paths it should manage.
  11. home.username = "hms";
  12. home.homeDirectory = "/home/hms";
  13. # This value determines the Home Manager release that your
  14. # configuration is compatible with. This helps avoid breakage
  15. # when a new Home Manager release introduces backwards
  16. # incompatible changes.
  17. #
  18. # You can update Home Manager without changing this value. See
  19. # the Home Manager release notes for a list of state version
  20. # changes in each release.
  21. home.stateVersion = "20.09";
  22. }