You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

118 lines
3.2 KiB

  1. ###################################################
  2. #
  3. # HMS NixOS Conf
  4. # 2020-8-29
  5. #
  6. { config, pkgs, ... }:
  7. {
  8. imports =
  9. [ # Include the results of the hardware scan.
  10. ./hardware-configuration.nix
  11. ];
  12. #### Boot
  13. boot.loader.grub.enable = true;
  14. boot.loader.grub.version = 2;
  15. boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
  16. #### Network
  17. networking.useDHCP = false;
  18. networking.interfaces.ens18.useDHCP = true;
  19. #### Time/Date
  20. time.timeZone = "America/Los_Angeles";
  21. #### Packages
  22. nixpkgs.config = {
  23. allowUnfree = true;
  24. };
  25. environment.systemPackages = with pkgs; [
  26. # Basics
  27. wget
  28. youtube-dl
  29. tmux
  30. neofetch
  31. sakura
  32. firefox
  33. # Editors
  34. vscode
  35. nano
  36. vim
  37. # Social
  38. discord
  39. signal-desktop
  40. # Design
  41. darktable
  42. inkscape
  43. gimp
  44. # Torrents
  45. transmission
  46. # Other
  47. simplenote
  48. # Auth
  49. yubioath-desktop
  50. ];
  51. #### Services
  52. services.sshd.enable = true;
  53. #### xserver
  54. services.xserver.enable = true;
  55. services.xserver.layout = "us";
  56. # Display Manager
  57. services.xserver.displayManager.lightdm.enable = true;
  58. services.xserver.displayManager.defaultSession = "none+awesome";
  59. services.xserver.displayManager.lightdm.greeters.mini = {
  60. enable = true;
  61. user = "hms";
  62. extraConfig = ''
  63. [greeter]
  64. show-password-label = true
  65. password-label-text = Enter Credentials:
  66. invalid-password-text = Credentials Invalid
  67. show-input-cursor = true
  68. password-alignment = right
  69. show-image-on-all-monitors = false
  70. [greeter-theme]
  71. background-image = ""
  72. font = "Sans"
  73. font-size = 1em
  74. font-weight = bold
  75. font-style = normal
  76. text-color = "#080800"
  77. error-color = "#F8F8F0"
  78. background-color = "#1B1D1E"
  79. window-color = "#F92672"
  80. border-color = "#080800"
  81. border-width = 2px
  82. layout-space = 15
  83. password-color = "#F8F8F0"
  84. password-background-color = "#1B1D1E"
  85. password-border-color = "#080800"
  86. password-border-width = 2px
  87. '';
  88. };
  89. # Desktop Manager
  90. #services.xserver.desktopManager.mate.enable = true;
  91. # Window Manager
  92. services.xserver.windowManager.awesome.enable = true;
  93. #### User
  94. users.users.hms = {
  95. isNormalUser = true;
  96. home = "/home/hms/";
  97. extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user.
  98. };
  99. # This value determines the NixOS release from which the default
  100. # settings for stateful data, like file locations and database versions
  101. # on your system were taken. It‘s perfectly fine and recommended to leave
  102. # this value at the release version of the first install of this system.
  103. # Before changing this value read the documentation for this option
  104. # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
  105. system.stateVersion = "20.03"; # Did you read the comment?
  106. }