You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

27 lines
748 B

  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, pkgs, ... }:
  5. {
  6. imports =
  7. [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
  8. ];
  9. boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "sd_mod" "sr_mod" ];
  10. boot.initrd.kernelModules = [ ];
  11. boot.kernelModules = [ ];
  12. boot.extraModulePackages = [ ];
  13. fileSystems."/" =
  14. { device = "/dev/disk/by-uuid/1972ba2d-a5fd-4d89-86a4-092a2645d27f";
  15. fsType = "ext4";
  16. };
  17. swapDevices =
  18. [ { device = "/dev/disk/by-uuid/6f3e3d02-70dc-4820-b6c6-41568fe57600"; }
  19. ];
  20. nix.maxJobs = lib.mkDefault 1;
  21. }